MGA -Singular Matrix error

Small talk on SmartPLS that does not correspond to the other forums!
Post Reply
KIHO KWON
PLS Junior User
Posts: 9
Joined: Tue May 15, 2018 1:37 am
Real name and title: Mr. KIHO KWON

MGA -Singular Matrix error

Post by KIHO KWON » Mon Jun 04, 2018 2:33 am

Hi.

I have 8 latent variables and 8 control variables.

In terms of the control variables, I have 4 categorical variables including gender, chatting experience, etc.
So I transformed these to dummy variables.
In result, 4 dummies ware made.

When I used standard bootstrapping(5000 times), I can get t statistics and p values.
But, when I used MGA to examine how the path coefficients are different between two groups(having chatting experience vs not having chatting experience), singular matrix error occurred.

How it can be possible?
In my humble opinion, because the standard bootstrapping was ok, both my dummies and data are ok as well.

greetings
KIHO KWON

jmbecker
SmartPLS Developer
Posts: 820
Joined: Tue Mar 28, 2006 11:09 am
Real name and title: Dr. Jan-Michael Becker

Re: MGA -Singular Matrix error

Post by jmbecker » Mon Jun 04, 2018 11:40 am

The variable that you use for defining the groups cannot be part of the model. It will have in each group only the same values and thus zero variance. It is not possible to calculate the models on such data.
Dr. Jan-Michael Becker, University of Cologne, SmartPLS Developer
Researchgate: https://www.researchgate.net/profile/Ja ... v=hdr_xprf
GoogleScholar: http://scholar.google.de/citations?user ... AAAJ&hl=de

Post Reply