Installing smartpls on linux

Report and discuss bugs of SmartPLS 2. To report bugs of the new SmartPLS 3 software, create a ticket in our helpdesk.
Post Reply
jlau
PLS Junior User
Posts: 3
Joined: Thu Oct 18, 2012 7:28 am
Real name and title:

Installing smartpls on linux

Post by jlau » Fri Oct 26, 2012 7:51 am

Hello Christian,

I have watched the video manuals and I am really looking forward to using smartpls.

I have downloaded the linux zip file and unzipped it. Then I changed the mode of the file smartpls to executable (I do not know if this is the right executable file, but it seemd the best candidate). When I run ./smartpls I see the openeing graphic for a second and then an error message pointing me to the log file. The log file starts like this:

!SESSION 2012-10-26 09:45:21.023 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_24
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 4 0 2012-10-26 09:45:21.553
!MESSAGE An error occurred while automatically activating bundle de.smartpls.platform.ui (57).
!STACK 0
org.osgi.framework.BundleException: Exception in de.smartpls.platform.ui.UiPlugin.start() of bundle de.smartpls.platform.ui.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1014)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:970)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:317)

etc.

So it seems that it is using java 1.6.24, which should be ok. I only unzipped the file I downloaded, not the .jar files or any other archive inside it. What am I doing wrong please.

I am running ubuntu 12.04 on a 64-bit machine.

Thanks.

Josef
Josef Lauri

User avatar
cringle
SmartPLS Developer
Posts: 797
Joined: Tue Sep 20, 2005 9:13 am
Real name and title: Prof. Dr. Christian M. Ringle
Location: Hamburg (Germany)
Contact:

Post by cringle » Fri Oct 26, 2012 1:47 pm

Hi

SmartPLS works fine on our Linux (i.e., Ubuntu). My first guess:
Do you use Java 32 bit?

Even though SmartPLS works fine on 64 bit machines, in needs to use a 32 bit JRE 6.

Best regards
Christian

jlau
PLS Junior User
Posts: 3
Joined: Thu Oct 18, 2012 7:28 am
Real name and title:

Installing smartpls on linux

Post by jlau » Sat Oct 27, 2012 9:38 am

Probably I have the 64-bit version since i have installed the 64-bit ubuntu and all the java I have is what came with the package. I have never messed around with java. Is it possible to install also the 32-bit jre without messing up the system? How should I do that?

Thanks.

josef
Josef Lauri

jlau
PLS Junior User
Posts: 3
Joined: Thu Oct 18, 2012 7:28 am
Real name and title:

Installing smartpls on linux

Post by jlau » Sat Oct 27, 2012 12:42 pm

Looked up the ubuntu fora and installing two version of the jre seems to need to much fiddling. So I worked around the problem by installing smarypls under Windows XP which I run under VirtualBox.

Thanks.

Josef
Josef Lauri

Post Reply